Monday, September 13, 2010

Dear openSUSE: Your 11.3 display settings doesn't do it for me

Dear openSUSE,

Upgrading from 11.2 to 11.3 went very smooth it seemed. (Except the little detail about you turning down the sound volume in alsamixer. That one wasn't nice of you.). But then I experienced black blocks of graphics from out of nowhere - not acceptable.

I figured the easiest way would be to reinstall the graphics card driver so I downloaded a fresh one from ATI. Seems the OS update did ruin something - now I can no longer build the fglrx-whatever.rpm? Careful studies at your ATI drivers wiki page did help and I now have a file called fglrx64_7_5_0_SUSE113-8.762-1.x86_64.rpm taking up 28.4 MB of space on my harddisk. It doesn't do much else because attempting to install it will result in a boot to some init 3 / console like state where "X can't be found" (something like that). Building and installing the proprietary (and fully functional) driver is something I have done "the hard way" with five or six previous versions.

Although in general I could probably study your anatomy in closer detail and should perhaps more specifically read through some online guide about your display settings configuration files I must admit to being disgruntled after having had to now completely reinstall you. Twice. On top of the update. Because even though I have taken backups of your xorg.conf files and have tried to put them back in place when the new ones didn't work - that haven't helped either.

I'm failing you as a geek, I know. But reinstalling has been my fix for your display problems. And perhaps you'll understand me when I tell you I had enough? Three times is enough for me. My interest in computers increasingly lies in actually using them, you know. And, believe it or not, now I simply find it easier to fix your display settings using KDE... every single time I log on because a) you boot in 1024x768 (low) resolution, b) obviously the changes made there are temporary and c) you have removed the configuration tool (sax2) now your automatic configuration works so well at install (sic!).

Now, I know I'm not running you on the easiest of hardware - dual screen, different resolutions - but still: It worked perfectly in 11.2, it's all common brands and recent models. Plus I am so much more tolerant and patient with you than most others. You should start figuring out how to make yourself attractive to the average guy. Because you and I could be drifting apart, baby.
How to change the display settings in openSUSE 11.3 / KDE 4.4.4
  1. Click the openSUSE gecko (green "start" button) then Configure Desktop - Personal Settings (tools icon).
  2. Click on Display (screen icon).
  3. Change the Size setting(s) to your preferred resolution. Most likely it is marked with the text (auto) -although it obviously isn't that automatic after all.





    The display settings I happen to desperately need.
  4. Click Apply.
  5. Confirm the settings within 15 seconds by clicking Accept Configuration (unless you made a mistake and can't accept).




    If you don't see this just wait 15 seconds and things will go back to normally bad.
  6. Repeat at every single login :-(

[Technical notes: I have been messing around with two common Samsung screens, an ATI Technologies Radeon HD 4770, ati-driver-installer-10-8-x86.x86_64.run and the standard open source radeon driver.]

PS: Yes, I consider going through some of the procedures described at the Configuring graphics cards wiki page. But just from peeking at it I sure understand why most would never consider this an option!

[Edit March 2011: Story continues at Dear openSUSE: Your 11.4 release is great. Thanks a lot!]